得意淡然,失意坦然;喜而不狂,忧而不伤。

不影响centos自带yum的python升级安装指南

Linux/Unix admin 817次浏览 已收录 0个评论 扫描二维码
因为曾经升级python导致yum不可用,遇到很多不方便,安装报错:
 
There was a problem importing one of the Python modules
required to run yum. The error leading to this problem was
 
网上找到一篇文章,安装过程如下:
 
CentOS中编译安装Python2.7其实很简单的,下面我们只使用了几步就成功的安装好,有需要的朋友一起来看看。

心血来潮,想学习一下Python,听说用来做爬虫还不错。先从运行环境开始入手,CentOS中已经内置了Python,但版本似乎比较老,通过python -V命令看到版本是2.4.3。目前Python 2.x的最新版本号是2.7.8,那么就开始动手升级一下。

首先,下载源码包,命令如下:

wget –no-check-certificate https://www.python.org/ftp/python/2.7.8/Python-2.7.8.tgz

这里需要特别注意一下,因为下载网址是https开头的,所以要给wget命令加上–no-check-certificate参数。

下载好源码包后,解压:

tar -zxvf ./Python-2.7.8.tgz

解压出Python-2.7.8这个目录后,我们开始对源码进行编译:

cd Python-2.7.8
./configure –prefix=/usr/local/python
make
make install

编译安装完成后,要替换掉系统自带的Python,但CentOS的yum依赖于Python工作,为了保证yum的正常运行,我们要在替换前,先将自带的Python更名备份,方法如下:

mv /usr/bin/python /usr/bin/python-2.4.3
ln -s /usr/local/python/bin/python /usr/bin/python

上面两行命令执行完后,可以分别用“python -V”和“/usr/bin/python-2.4.3 -V”来验证部署是否成功,正确的结果应该是2.7.8和2.4.3。

最后,要修改yum,让其运行指向旧的版本:

vi /usr/bin/yum

将第一行中的“#!/usr/bin/python”修改为“#!/usr/bin/python-2.4.3”,保存即可


pitata技术乐园 , 版权所有丨如未注明 , 均为原创丨本网站采用BY-NC-SA协议进行授权 , 转载请注明不影响centos自带yum的python升级安装指南
喜欢 (0)
[103531948@qq.com]
分享 (0)
发表我的评论
取消评论
表情 斜体

Hi,您需要填写昵称和邮箱!

  • 昵称 (必填)
  • 邮箱 (必填)
  • 网址